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1 DWG/DXF file 
translator
About Translator Utilities

DWG/DXF file translator

Overview of DWG/DXF file translator
The DWG/DXF file translator plug-in extends Maya to help address the 
needs of those customers familiar with files in Autodesk’s DWG or DXF 
format. This data translator is capable of both reading existing DWG/DXF 
files into Maya and exporting files from Maya to the DWG or DXF format. 
The translator supports the import and export of AutoCAD files as recent 
as AutoCAD 2004.

Install DWG/DXF translator

This translator is installed with Maya.

Import/Export DWG/DXF files

To load the DWG/DXF file translator

1 Open Maya and select Window > Settings/Preferences > Plug-in 
Manager.

2 Click the loaded button for the DWG/DXF plug-in, dwgTranslator. 

To import a DWG/DXF file

• Select File > Import and select the DWG/DXF file you want to open 
from the file browser selection. 

To export a DWG/DXF file

• Select File > Export All or File > Export Selection, and choose 
DWGExport or DXFExport from the File of type drop-down list. 

Version compatibility

You can read (import) and write (export) versions as recent as AutoCAD 
2004.

DWG/DXF Import Options

To access these options, the DWG/DXF translator plug-in must be loaded, 
and you must change the File Type drop-down box to DWG_DXF.
Translators
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1 | DWG/DXF file translator
About > DWG/DXF file translator
Override file units with

Interpret the values specified by the DWG/DXF file as values with 
units as specified by the user in the adjacent drop-down box.

Scale Factor

Scale all imported geometry by a common factor. This allows very 
large scenes to be viewed more easily. 

DWG/DXF Export Options

To access these options, the DWG/DXF translator plug-in must be loaded, 
and you must change the File Type drop-down box to DWG_DXF.

General Options

Output File Format

The version of AutoCAD that dictates the DWG or DXF format. 
(default: ACAD2004).

Units

The units that are used as the export units (default: centimeters).

Scale Factor

The factor by which the resulting geometry in the DWG/DXF file is 
scaled upon export (default: 1.0000).

Precision

(DXF only.) The precision of the values used in the scene. Single 
precision supports 8 digits after the decimal, and double precision 
supports 17 digits after the decimal. Selecting Custom allows you to 
specify the number of supported digits following the decimal in the 
adjacent text box (default: Double(17)).

Note DWG/DXF files often contain geometry that is very large. 
In order to view this geometry properly, Scale Factor can be 
used to scale it down. Otherwise, in the viewing window, 
select View > Frame All to frame your selection, and if the 
geometry does not appear, it is beyond the camera’s rear 
clipping plane. Select View > Camera Attribute Editor and 
set the Far Clip Plane to a value sufficiently large such that 
the geometry is visible.
Translators
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1 | DWG/DXF file translator

About > DWG/DXF file translator
Include Comments 

(DXF only) appends comments to the generated DXF file. These 
include comments such as the Maya version, the date and time the file 
was generated, and the units of the file (default: false).

Polygon Mesh Options

Tessellation

Tessellates polymesh geometry on export. The Maya scene remains 
unaltered while the resulting DWG/DXF scene is either Triangulated 
or Quadrangulated, depending on the option selected. (default: No 
tessellation)

Export As

Allows polymesh geometry to be exported either as a single polyface 
mesh, separate polyfaces, or as 3D faces. (default: Polyface Mesh)

NURBS Surface Tessellation Options

NURBS surfaces are currently exported as polyface meshes.

Type 

Determines whether the surface is triangulated or quadrangulated on 
export. (default: Quadrangulate)

Method

Determines the method of tessellation

General  Requires that the user specify which subdivisions 
types are to be used in the tessellation. For each 
subdivision type the corresponding parameters 
must be set. "U Type", "Number U", "V Type" and 
"Number V" are all options that specify how the 
general tessellation is carried out.

Standard Fit  Tessellates the surfaces with standard fit ratios. The 
parameters for this type of refinement are "Chord 
Height Ratio", "Fractional Tolerance", "Minimal 
Edge Length", and "3D Delta".

Count Uses the specified triangle "Count" as a rough 
estimate of the triangles produced in the 
tessellation.

Known Issues

• 3D Solids (import): 3D solids are currently imported as blocks 
references containing SOLID entities. Workaround: Convert to 
polygons prior to export. (Modify > Convert > Subdiv to Polygon)
Translators
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1 | DWG/DXF file translator
About > DWG/DXF file translator
• NURBS surfaces (export): NURBS surfaces are exported as tessellated 
polyface meshes.

DXF entity support

DXF entities supported in Maya

DXF Entity

ARC no thickness

ARC with thickness

CIRCLE no thickness

CIRCLE with thickness

POINT, with thickness

LINE/3DLINE no thickness

LINE/3DLINE with thickness

3DFACE/SOLID/TRACE

POLYLINE/3D open

POLYLINE/3D closed

POLYLINE/3D with thickness

POLYLINE/3D Mesh

POLYLINE/Polyface Mesh

BLOCK

INSERT

LAYER
Translators
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2 IGES Translator 
plug-in
About Translator Utilities

IGES Translator plug-in

Overview of IGES Translator plug-in

The IGES file translator plug-in extends Maya to help address the needs of 
those customers familiar with files in the IGES format. This data translator 
is capable of both reading existing IGES files into Maya and exporting files 
from Maya to the IGES format. 

Install IGES translator

This translator is installed with Maya.

Import/Export IGES files

To load the DWG/DXF file translator

1 Open Maya and select Window > Settings/Preferences > Plug-in 
Manager. 

2 Click the loaded button for the DWG/DXF plug-in, IGES. 

To import a IGES file

• Select File > Import and select the IGES file you want to open from the 
file browser selection. 

To export an IGES file

• Select File > Export All (or File > Export Selection), and choose IGES 
from the File of type drop-down list. 

IGES import options

To access these options, the IGES translator plug-in must be loaded, and 
you must change the File Type drop-down box to IGES.

Default Trim Curves

Select Parameter Space trimming (curves defined in the parameter 
space of the surface) or World Space trimming (curves defined in 
world space of the model). The default is to use parameter space 
trimming. 
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2 | IGES Translator plug-in
About > IGES Translator plug-in
IGES Trim Flag. In IGES a trimmed surface can specify its preferred 
trimming method, either world space or parameter space. Choosing 
this option tells Maya to use whatever method is preferred in the file.

Scale Factor

Scales all imported geometry by a common factor. This allows very 
large scenes to be viewed more easily. 

Level Mapping

Controls whether layers from a IGES file are imported. The default is 
to always import layers.

IGES export options

To access these options, the IGES translator plug-in must be loaded, and 
you must change the File Type drop-down box to IGES.

Scale Factor

Determines the factor by which the resulting geometry in the IGES file 
is scaled upon export (default: 1.0000).

Known Issues

• If there is IGES created geometry in the scene then the plugin cannot 
be unloaded. Delete all data and unload plugin.

• The 500 Series (BREP) entities are unsupported.

IGES entity support

IGES entities supported in Maya

Note IGES files often contain geometry that is very large. In order 
to view this geometry properly, the Scale Factor can be used 
to scale it down. Otherwise, in the viewing window, select 
View > Frame All to frame your selection, and if the 
geometry does not appear, it is beyond the camera's rear 
clipping plane. Select View > Camera Attribute Editor and 
set the “Far Clip Plane” to a value sufficiently large such 
that the geometry is visible.

Typ
e

For
m

IGES Entity

100 0 circular arc
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2 | IGES Translator plug-in

About > IGES Translator plug-in
102 0 composite curve

104 0-3 conic arc

106 1 copious data

106 2 copious data

106 11 copious data

106 12 copious data

106 63 closed area

108* 0* plane

108 1 plane

110 0 line

112 0 parametric curve

114 0 parametric surface

118 0-1 ruled surface

120 0 surface of revolution

122 0 tabulated cylinder

124 0 transformation matrix

126 0-5 rational b-spline curve

128 0-9 rational b-spline surface

130 0 offset curve

140 0 offset surface

141 0 boundary entity

142 0 curve on surface

143 0 bounded surface

144 0 trimmed surface

308 0 subfigure definition
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2 | IGES Translator plug-in
About > IGES Translator plug-in
402 7,9 associativity instance

406 1 property - definition levels

408 0 singular subfigure instance

406 15 name
Translators
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3 StudioImport Plug-
in and Translator
About Translator Utilities

StudioImport

StudioImport is a translator for Studio wire files (previously known as 
Alias wire files). 

To load the StudioImport file Translator

1 Start Maya and select Window > Settings/Preferences > Plug-in 
Manager.

2 Click the loaded check box for the StudioImport plug-in.

To open a Studio wire file

• Select File > Open Scene and select the Studio wire file you want to 
open from the file browser selection.

StudioImport conversion issues

The following are known issues for StudioImport conversion as of Maya 
5.0.

• Studio SID data is not supported in the StudioImport plug-in. 

• Any paint data is not translated into Maya. SID shapes translate as 
Maya surfaces.

• Poly sets lose texture coordinates on translation to Maya. 

• Area and Linear lights are not transferred correctly. 

Note StudioTools v10 now uses a different file format for its wire 
files. This new file format should cause no change in your 
everyday use of StudioTools because the file provides all of 
the same capabilities as the old wire file. This new file 
format is compatible with new releases of StudioTools, so 
you won't need a translator to use Version 10 files in future 
releases.
Translators
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3 | StudioImport Plug-in and Translator
About > StudioImport
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4 Export plug-ins
About Translator Utilities

MayaToAlias export plug-in

MayaToAlias is a Maya plug-in for IRIX, Linux and Windows that uses 
OpenMaya API to get the scene information from Maya, and then exports 
it using OpenModel to one of the following, depending on which export 
file format is chosen:

• a wire file (version 9.7.3)

• IGES file

• DXF file

MayaToAlias exports the following from Maya to wire files:

• transform nodes 

• hierarchy 

• instanced objects 

• NURBS curves 

• NURBS surfaces 

• trimmed surfaces 

• meshes 

• cameras

MayaToAlias exports the following from Maya to IGES format:

• transform nodes 

• instanced objects (become copied objects in IGES)

• NURBS curves

• NURBS surfaces 

• trimmed surfaces 

• meshes 

MayaToAlias exports the following from Maya to DXF format:

• transform nodes 

Note The MayaToAlias plug-in is not available for Mac OS X 
systems.
Translators
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4 | Export plug-ins
About > Wavefront (OBJ) export plug-in
• instanced objects (become copied objects in DXF)

• NURBS curves 

• NURBS surfaces 

• trimmed surfaces (become surfaces and curves in DXF)

• meshes 

To load the MayaToAlias plug-in

1 Open Maya and select Window > Settings/Preferences > Plug-in 
Manager.

2 Click the loaded check box for the MayaToAlias plug-in.

Now you can export Maya content to wire, IGES, or DXF format 
through the usual export mechanism.

To export a Maya file to wire, IGES, or DXF

1 Select File > Export All or File > Export Selection. 

2 Select a file name and file type, and then click Export. 

aliasWireExport, IGESexport, and DXFexport are three of the options 
in the File Type pull-down menu.

Troubleshooting

• If you get an error message when using MayatoAlias of the form 
“Creating surface fails - node [nodename], it is because Studio Tools 
and Maya have different requirements for a valid NURBS surface. 
Valid NURBS surfaces in Maya may not be valid in Studio Tools, 
hence they are not created. Usually the problem can be fixed by 
changing Open to Periodic in either U or V direction (this can be done 
by using the Edit Surfaces > Open/Close Surfaces tool. Ensure that 
the Surface direction is set correctly by opening the option box).

Wavefront (OBJ) export plug-in

The objExport plug-in lets you export Maya polygon data to the 
Wavefront OBJ ASCII file format. It successfully converts:

• Maya texture coordinate and vertex normal information.

• Maya renderable set information into material names.

• Maya component set information into groups.

For details on exporting to OBJ format, see Basic Tools.
Translators
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4 | Export plug-ins

About > RenderMan (RIB) export plug-in
To load the objExport plug-in

1 Open Maya and select Window > Settings/Preferences > Plug-in 
Manager.

2 Click the loaded check box for the objExport plug-in.

To export a file in OBJ format

1 Select File > Export All or File > Export Selection.

2 Choose OBJexport as the file type and then click Export.

RenderMan (RIB) export plug-in

The ribExport plug-in adds the new file format RIBexport to the File > 
Export All options menu. This lets you export scenes created in Maya in 
the RIB (RenderMan) format.

The ribExport plug-in supports ambient, directional, point, and spot 
lights. Simple non-textured shaders are supported, although only the 
shader color is exported. All other shading attributes are ignored. Phong 
and Blinn shaders are exported as “plastic”; Lambert shaders are exported 
as “matte.” Per-face shading groups are not supported; only shading 
groups that are assigned to objects or object instances are exported.

When exporting Maya scenes into RIB, note that the # character is a 
special formatting character in RenderMan image names. To include a real 
# character in a RenderMan image name, you must use “##”. (See section 
4.1.10 of the RenderMan user manual for information on formatting.)

Note objExport does not export OBJ formatted curves, surfaces, 
smoothing groups, or point group materials. It also does not 
support NURBS. Use the MayaToAlias plug-in for scenes 
that contain NURBS surfaces.

Note Alias provides the source code for the objExport plug-in as 
part of the Maya Developer’s Toolkit. Ensure that you have 
installed the Toolkit, and you can find the source code in 
.../devkit/plug-ins/objExport.cpp.

Note This plug-in only supports the Export All file access mode. 
RIB file import is not supported.
Translators

17



4 | Export plug-ins
About > RenderMan (RIB) export plug-in
The image name constructed by the ribExport plug-in includes the 
contents of the “imageName” attribute of the renderable cameras. If you 
want to include the special RenderMan formatting characters in an image, 
the imageName attribute is the place those characters should be placed.

To load the ribExport plug-in

1 Open Maya and select Window > Settings/Preferences > Plug-in 
Manager.

2 Click the loaded check box for the ribExport plug-in.

To export a file in RIB format

1 Select File > Export All.

2 Select RIBexport as the file type and then click Export.

RIBexport Options

Default File Extensions

Specifies whether the .rib extension is appended to the specified file 
name. The .rib extension is not added if the specified filename 
already contains that extension.

Single File Output

If Yes, all frames is written to a single .rib file. If No, all frames are 
written to separate .rib files.

Extension Padding

If the Single File Output option is off, this option specifies whether the 
RIB file extensions is padded with 0’s.

Geometry Motion Blur

Specifies if geometry motion blur information is written to the RIB 
file.

Pixel Samples

Specifies the number of samples taken for each pixel. This value is 
used for both the X and Y directions.

Note Alias provides source code for the ribExport plug-in as part 
of the Maya Developer’s Toolkit. If you install the Toolkit, 
you can find the source code in .../devkit/plug-ins/
ribExport.cpp.
Translators
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5 Maya OpenFlight 
Importer/Exporter
About Translator Utilities

OpenFlight

Overview of OpenFlight

The OpenFlight file translator plug-in provides extended functionality to 
Maya to help address the needs of the Visual Simulation customer. This is 
done by providing a data translator to read the currently existing 
OpenFlight databases into Maya. Accompanying the OpenFlight database 
importer is an OpenFlight Exporter. Functionality that was found to be 
missing from Maya was added in the form of new node types that can be 
created and edited from within the Maya modeling environment.

OpenFlight is installed with Maya.

Import/export OpenFlight files

To load the OpenFlight file Translator

1 Open Maya and select Window > Settings/Preferences > Plug-in 
Manager.

2 Click the loaded check box for the Open/Flight plug-in, fltTranslator.

OpenFlight is a 3D file format. The file importer/exporter is an OpenMaya 
plug-in. Any of the Beads that can be imported into Maya can also be 
exported (see ”Supported OpenFlight Beads” on page 30). 

The exported file contains a subset of the imported data. External file or 
texture references point to the referenced files in their current directories. 
Should it be necessary to move an exported file to a location that does not 
allow access to the original file references, these referenced files can be 
copied into the same directory as the target OpenFlight file and the 
references read correctly.

To open an OpenFlight file

• Select File > Open Scene and select the OpenFlight file you want to 
open from the file browser selection.

To export an OpenFlight file

• Select File > Export All (or File > Export Selection), and choose 
OpenFlight from the File of type drop-down list.
Translators
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5 | Maya OpenFlight Importer/Exporter
About > User Interface
Version compatibility

You can read (import) versions from 14.2 up to 15.7, but only export 15.7 
files. 

User Interface

OpenFlight Menu

An OpenFlight menu is added to the main window when the OpenFlight 
plug-in is installed. The menu contains the following menu items:

OpenFlight > Create Light Points

Invokes the fltLightPoints command to create a new set of light points in 
the scene. 

OpenFlight > Create Light Points > 

Number of Light Points

Sets the number of light points.

Distance Between Light Points

Set the distance between light points.

Light type

Choose one of Omnidirectional, Unidirectional, or Bidirectional.

Light Normal

Only active when the light type is unidirectional or bidirectional. Set 
the light normal.

Light Color

Set the light color.

OpenFlight > Create Lights on Curve

Invokes the fltLightsOnCurve script to create light points along a selected 
curve. 

Note The light colors only appear in shaded mode. Turn on 
Smooth Shading to see the colors.
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About > OpenFlight > Edit Light Points Color
OpenFlight > Create Lights on Curve > 

Number of Light Points

Sets the number of light points.

Light type

Choose one of Omnidirectional, Unidirectional, or Bidirectional.

Light Color

Set the light color.

OpenFlight > Edit Light Points Color

Used to change the color of selected light points.

To change the color of selected light points

1 Select the light points to modify. 

2 From the OpenFlight menu, select Edit Light Points Color.

The Light Points Color Editor appears.

3 Select the color to apply to these light points in the color slider. 

4 Press the Apply (or Apply and Close) buttons to apply the color to the 
selected light points. 

This dialog box works with light points selected in object mode and with 
light points selected in component mode.

OpenFlight > Edit Light Points Normal

Allows you to change the normal of any selected light points. 

To change the normal of any selected light points

1 Select the light points to modify. 

2 From the OpenFlight menu, select Edit Light Points Normal.

The Light Point Normal Editor appears. 

3 Enter the value of the new normal to apply to these light points. 

4 Press the Apply (or Apply and Close) to apply set the normal of the 
selected light points. 

Note The light colors only appear in shaded mode. Turn on 
Smooth Shading to see the colors.
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This dialog box works with light points selected in object mode and with 
light points selected in component mode.

Workflow Considerations

The following are workflow issues you should consider when working 
with OpenFlight files in Maya.

When importing files

OpenFlight models are built with a Z-up axis up orientation. When a 
model is read into Maya using File > Open, the default orientation in 
Maya is repositioned so that Z is the up vector (normally Maya’s Y axis is 
oriented as the up vector). 

When files are read into Maya using File > Import, the orientation is not 
affected by the import. You must correctly orient the imported data 
yourself. 

When exporting files

Here are some of the limitations to consider when exporting an 
OpenFlight file from Maya:

• Models are always exported in color RGB mode.

• The units are always meters.

• No animation can be exported.

• No cameras can be exported.

• The exporter only supports a single texture map per face. Layered 
textures results in only the first texture being exported.

• 2D and 3D procedural textures are not exported.

• Many Maya rendering parameters have no direct equivalent in 
OpenFlight.

• Degree of Freedom Beads are only created when Limits are set on a 
Maya group/transformation node.

• No transformations on externally referenced nodes are saved out to 
OpenFlight format. To transform a referenced file from within the 
current scene, the DAG root objects in the referenced file should be 
grouped, and any transformations should be applied to the group 
node.
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Shading Models

Flat Shading

OpenFlight objects have a flat shading flag, which specifies whether the 
object is to be drawn with flat shading or Gouraud (smooth) shading. This 
flag is now connected with the "Smooth Shading" attribute of polygons in 
Maya (as found in the Render Stats tab of the Attribute Editor for the 
shape).

While OpenFlight supports the flat shading flag at the object level as well 
as at the face level, Maya only supports the flag at the object level. Thus, 
the flat shading flag of any object imported into Maya must be set 
identically for the object and all its faces.

Illumination

The illumination flag of OpenFlight objects specifies whether the object is 
to be illuminated by nearby lights or whether it is exclusively self-
illuminating. 

When importing a self-illuminating object, the following attributes of the 
corresponding Maya object are turned off: "Casts Shadows", "Receive 
Shadows", "Visible in Reflections" and "Visible in Refractions". When the 
imported object is not self-illuminating, all these attributes are turned on.

When exporting a Maya object to OpenFlight, the self-illumination flag is 
set if and only if the "Receive Shadows" attribute of the Maya object is 
turned off.

When using Switch Nodes

Support has been added to Maya for OpenFlight Switch nodes. Switch 
nodes allow for an array of visibility masks to be applied to a group 
transform node. Each child node’s visibility is represented by one bit in 
the visibility mask. (Current implementation only supports up to 32 
children.)

The switch node is implemented as a helper node that is applied to a 
group transform node and can be viewed and selected through the 
Hypergraph. The currently selected mask can be modified through the 
Attribute Editor associated with the switch node. 

Switch Nodes are created automatically when an OpenFlight database 
with Switch Nodes is read into Maya. They may also be created using the 
fltSwitch command from within the Maya modeling environment.

Switch node attributes

Name Long (Short) Type Default Flags
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fltSwitch Command

Synopsis

FltSwitch [flags]

Return Value

[string[]] (object name or node name on create)

Description

This command is used to create, edit or query Switch Nodes from 
within Maya.

Flags

-p (c) The parent group transform node.

-cm (eq) Set or query the current switch node mask.

-n (ceq) The name of the node to be operated on.

-am (e) Append a mask based on the current object selection.

-em (e) Edit the currently active mask based on the current object 
selection.

-dm (e) Delete the current mask.

Example

// Create a Switch node
fltSwitch -n sw1;
// After some geometry has been added under sw1, masks maybe 
created by selecting the geometry to be visible under the 
switch for the mask and and then using the fltSwitch command 
as follows.
fltSwitch -e -am -n sw1;
// Setting the current mask to the desired switch will 
enable that mask.
fltSwitch -e -cm 0 -n sw1;

outputVis (out) Tint32 0 R

curMask (in) Tint32 0 RWSK

maskWidth (mkw) Tint32 0 RWS

numMasks (nmk) Tint32 0 RWS

masks (mks) Tint32 0 ARWS
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When using Light Points

Support has been added to Maya for OpenFlight Light Points. Light Points 
allow for an array of lights to be created that have no render properties. 

They can be imported & exported into OpenFlight files, with the following 
restrictions

Import

• Modeling lights are not supported

• OpenFlight Infinite lights are imported into Maya as directional lights

• OpenFlight Local lights are imported into Maya as ambient lights

• OpenFlight Spot lights are imported into Maya as spot lights

Export

• Directional lights are exported as infinite lights

• Ambient lights are exported as local lights

• Spot lights are exported as spot lights

• Light types not supported by OpenFlight (area lights, point lights) are 
exported as infinite lights

• Modeling lights are not supported

Light Points are implemented as a shape in Maya. They are created 
automatically when an OpenFlight database with Light Points is read into 
Maya. Additionally, Light Points can be created from within Maya using 
the OpenFlight menu commands or the MEL command, fltLightPoints.

Each Light Point Shape can contain any number of Light Points. By 
selecting a Light Point Shape and opening its Attribute Editor, all Light 
Points attributes are available. Many of these attributes have no visible 
effect within Maya but can still be edited, saved, and exported.

Light Point attributes

Notes • One light palette is created for each light source

• The orientation of the light palette is always Yaw = 0, 
Pitch = 0

Name Long (Short) Type Default Flags

LightPointsMin (lpmn) double3 0 RWS

LightPointsMax (lpmx) double3 0 RWS
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SurfaceMaterialCode (smc) Tint16 0 RWS

FeatureId (fid) Tint16 0 RWS

BackColor (bc) Tint32 0 RWS

DisplayMode (dm) Enum 0 RWS

Intensity (ity) Float 0 RWS

BackIntensity (bit) Float 0 RWS

MinimumDefocus (mndf) Float 0 RWS

MaximumDefocus (mxdf) Float 0 RWS

FadingMode (fm) Tint32 0 RWS

FogPunchMode (fpm) Tint32 0 RWS

DirectionalMode (drm) Tint32 0 RWS

RangeMode (rm) Tint32 0 RWS

MinimumPixelSize (mnps) Float 0 RWS

MaximumPixelSize (mxps) Float 0 RWS

ActualSize (aps) Float 0 RWS

TransparentFalloffPixelSize (tfps) Float 0 RWS

TransparentFalloffExponent (tfe) Float 0 RWS

TransparentFalloffScalar (tfs) Float 0 RWS

TransparentFalloffClamp (tfc) Float 0 RWS

FogScalar (fs) Float 0 RWS

SizeDifferenceThreshold (sdt) Float 0 RWS

DirectionalType (drt) Enum 0 RWS

HorizontalLobeAngle (hla) Float 0 RWS

VerticalLobeAngle (vla) Float 0 RWS

DirectionalFallofExponent (dfe) Float 0 RWS
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Light point functionality has been extended to display the affects of 
several more attributes of light point shapes:

• Directional Type

• Intensity

• Directional Ambient Intensity

• Back Intensity

• Horizontal Lobe Angle

• Vertical Lobe Angle

• Roll Lobe Angle

DirectionalAmbientIntensity (dai) Float 0 RWS

AnimationPeriod (ap) Float 0 RWS

AnimationPhaseDelay (apd) Float 0 RWS

AnimationEnabledPeriod (aep) Float 0 RWS

Significance (sig) Float 0 RWS

Calligraphic (call) Tint32 0 RWS

Flags (flgs) Tint32 0 RWS

XanimRotateAxis (xra) Float 0 RWS

YanimRotateAxis (yra) Float 0 RWS

ZanimRotateAxis (zra) Float 0 RWS

LightColors (lc) Double3 0 ARWS

LightNormals (ln) Double3 0 ARWS

InputLightPoints (ilp) 0x58000014 0 RW

OutputLightPoints (olp) 0x58000014 0 RS

WorldLightPoints (wlp) 0x58000014 0 ARS

CachedLightPoints (clp) 0x58000014 0 RWS

DisplayNormals (dn) Boolean false RWSK

DisplayLobe (dl) Boolean false RWSK
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• Normals Display

• Lobe Display

Both Normals Display and Lobe Display have no Creator equivalent. They 
are used to control the visibility of the normal and lobe of light points as 
you develop your scene inside of Maya. Note that you cannot display 
lobes of omni-directional lights.

Currently the back color only displays as red regardless of the actual 
value set. This default color does respond to the back and ambient 
intensities to enable more sophisticated simulation.

fltLightPoints Command

Synopsis

fltLightPoints [flags]

Return Value

[string[]] (object name or node name)

Description

This command is used to create Light Points from within Maya.

Flags

-d (c) The distance between light points.

-c (c) The number of light points to be created.

-n (c) The node name to be created.

-p (c) The parent group transform node.

-nt (c) If specified, then no parent transform is created. In this case a 
parent must also be specified with the –p flag.

-clr (ce) The RGB color value to be applied to all created light points. 
Each value should be in the range from 0.0 - 1.0. In edit mode if no 
light points are selected then the light point shape name must be 
specified using -n.

-nml (ce) The Normal to be applied to all created light points. In edit 
mode if no light points are selected then the light point shape name 
must be specified using -n.

dt (ce) Type must be one of: "OMNIDIRECTIONAL", 
"UNIDIRECTIONAL", or "BIDIRECTIONAL". By default, light points 
are omnidirectional.

 -dnml (ce) Enable or Disable the display of normals (true/false
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Example

// Create 3 light points spaced 0.5 UI units apart
fltLightPoints –c 3 –d 0.5/

/ this creates a light point string with 5 light points and 
visible normals
fltLightPoints -c 5 -dnml true;

// this makes the normals of the selected light points 
string invisible and
// changes the light type to be Unidirectional.
fltLightPoints -e -dnml false -dt UNIDIRECTIONAL;

fltLightsOnCurve Script

Synopsis

fltLightsOnCurve [arguments]

Return Value

None

Description

This script uses an existing curve and creates a given number of Light 
Points using the currently selected curve as a placement guide. The 
Light Points are evenly spaced along the curve. 

Note—The curve is used for construction purposes only and is 
modified by this script.

To use this script

1 Create a curve to use as a placement guide for the Light Points. 

2 Select the curve and then execute the script.

Example

// Create 3 Red Light Points equally spaced along the 
selected curve
fltLightsOnCurve 3 1.0 0.0 0.0;

Arguments

Arg1 An integer that specifies the number of Light points to be 
created.

Arg2 A float that specifies the Red component of the assigned color 
for the Light Points (0.0 – 1.0)

Arg3 A float that specifies the Green component of the assigned color 
for the Light Points (0.0 – 1.0)
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Arg4A float that specifies the Blue component of the assigned color 
for the Light Points (0.0 – 1.0)

Degree Of Freedom (DOF) Nodes

All transform nodes in Maya can represent DOF nodes. They each have 
limit information available and by default work within their own co-
ordinate space. 

To create a DOF from a Maya transform node

• Set a limit on a group transform node from the Attribute Editor.

Level Of Detail (LOD) Nodes

Maya’s LOD nodes work slightly differently from the OpenFlight LOD 
nodes. To simulate the behavior of OpenFlight LOD nodes, all children of 
an OpenFlight LOD node are grouped together under a single group 
transform node that is controlled by the LOD node. A null transform node 
can also be inserted before and/or after the controlled LOD node to satisfy 
Maya’s switch in/switch out requirements. 

Maya’s LODs are also tied to a particular camera. When importing an 
OpenFlight file, a camera named fltLOD is created. To activate the LOD 
behavior, you must use this camera. If new LOD nodes are created from 
within Maya, they should likewise be associated with the LOD camera.

Supported OpenFlight Beads

The following table provides comparisons between OpenFlight and Maya.

Note Deleting these nodes cause the LOD to behave incorrectly.

OpenFlight Beads Maya equivalent/comment

Control Records

Instance Definition Instanced geometry

Instance Reference Instance group node

POP Changes move up to the previous parent in the DAG
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PUSH Creates a child under the current parent

Unsupported Control Records 

Extension

POP Subface See PUSH Subface

PUSH Subface Maya cannot support hierarchy on co-planer surfaces. Instead the 
next face to be created is offset by 1 mm in the direction of the normal.

Pop Attribute Reserved for MultiGen

Push Attribute Reserved for MultiGen

Primary Records

Degree-of-Freedom 
Record

Maya transforms are used to represent DOF’s. See ”Workflow 
Considerations” on page 22 for more information. 

EXTERNAL 
REFERENCE

File reference to another OpenFlight database.

FACE Shape node for a face. Faces are part of a polymesh within Maya.

GROUP Group transform node.

HEADER Header record for an OpenFlight file. Sets orientation, field of view, 
etc. Sets the appropriate orientation and UI units.

Level-of-Detail Level of detail group node.

Light Source A Light.

Light Point A special node type associated with the OpenFlight translator. See 
”When using Light Points” on page 25” for more details.

OBJECT Transform node.

SWITCH A special node type associated with the OpenFlight translator. See 
“Switch Nodes” under “Work Flow Considerations” for more details.

Unsupported Primary Records

Binary Separating 
Plane

Allows for the modeling of databases without Z information

Curve B-spline, Cardinal, also known as Catmull-Rom, and Bezier.
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CAT Continuously Adaptive Terrain Skin. A triangle mesh for high 
fidelity, real-time viewing.

Clip Region

Extension Node User defined node information.

MESH Poly mesh. (This is not widely supported and may not be available in 
the first release)

Morph Vertex List Works in conjunction with LOD node to morph geometry depending 
on the distance from the camera.

Road Segment

Road Construction

Road Path

Sound Sound emitter position

Text

Ancillary Records

Continuation Not a node but simply a continuation of a vertex list. Records are 
limited to 64K in size.

LONG ID A node name greater than 7 characters to be applied to the previously 
read node. Maya node names do not have this restriction so the name 
is applied directly to the node.

REPLICATE Multiple instances of the current transform node.

TRANSFORMATION 
MATRIX

Transform matrix to be applied to the current transform node.

Unsupported Ancillary Records

Bounding Volume

CAT Data Header

CAT Data Key

CAT Data Face

Extension Attribute 3rd party support.
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Local Vertex Pool

MESH PRIMITIVE

MultiTexture Allows support for up to 8 textures per vertex (May not be in first 
release).

Road Zone (Pointer to a file that contains grid elevation data)

UV List Follows Vertex List and contains texture layer information.

Vector (Only used for light point faces).

Palette Records

Color Palette A collection of color entries. Maya does not use a color palette. Each 
vertex holds the corresponding RGB color.

LIGHT PALETTE Lights are DAG node entries in Maya.

MATERIAL PALETTE Material become Shaders within Maya. See Texture Palette

TEXTURE PALETTE Textures are applied to shaders within Maya. Shaders have an 
associated shading group that all nodes using this texture are 
connected to. 

Eyepoint and 
Trackplane Palette

Implemented as Cameras in Maya. (See ”Known Issues” on page 34.)

Light Source Palette

VERTEX PALETTE Vertices are part of a polymesh in Maya.

VERTEX LIST See Vertex Palette.

Vertex Palette Header Followed by vertex data.

Vertex with Color Polymesh vertex data.

Vertex with Color and 
Normal

Polymesh vertex data.

Vertex with Color, 
Normal and UV

Polymesh vertex data.

Vertex with Normal 
and UV

Polymesh vertex data.

Unsupported Palette Records
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Known Issues

The following outlines the known issues in OpenFlight Version 1.1.

• It is not possible to change the Maya display color of a unidirectional 
or bi-directional light. This color always defaults to red. It is expected 
that future releases will have the ability to map back colors to RGB 
display.

• An attempt is made to map Eye Points to Cameras in Maya; however, 
the mapping appears incorrect in some cases. Eye points are not 
exported from Maya.

• Track Planes are not supported.

• The only way to freeze a DOFs co-ordinates from within Maya is to 
export the scene as an OpenFlight file and then read it back in.

• Articulations on group nodes are not supported.

• Maya's LODs need to be extended to better handle the flexibility of 
the OpenFlight LODs.

• UI-based tools are missing to support Switch nodes, and LODs.

• If you perform a Freeze Transformations on a translated Light Point, 
Maya versions older than 4.0.3 will crash. This can be fixed by 
updating to Maya 4.0.3.

• File textures may only be applied to the color attribute of a Maya 
shader. Textures applied to other attributes are ignored.

•  The only export type supported is OpenFlight 15.7.

Key Table

Linkage Palette

Line Style Palette Maya has only 1 line style.

Name Table

Sound Palette

Texture Mapping
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